2D benchmarks on Linux Nvidia, Intel, ATI: xrender

For my new computer I bought a ATI HD 2600 PRO with a bunch of memory. This card has some really good 3D results, and works well on Linux. But I run into some issues with de xv extension on this board. In fact the driver (the free or binary one) doesn’t seems to support sync on vblank. So when a app try do display datas on the screen, some image destructions appear. This mainly occurs when I’m watching videos but in 3D games too. This is a really stupid bug or mis-feature. How can a serious video programmer can do that ?

After a couple of month, I decided it was enough, I was sick of this dirty stripes on screen. I tested every ATI driver one after one … (ATI opensource drivers have too bad performances to be used on a every days desktop, could you live without google-earth ? ) .. so I decided to go to other side, and bought a Nvidia 8600GT from ASUS. This card perform quite as the ATI in 3D, and have a affordable price. So I switched from ATI to Nvidia.

ATI offers better opensource support, but Nvidia binary driver is really nice to use and have better support today from stuffs like Compiz and Co.. and NO MORE STRIPES !! :)

A couple of weeks ago, I upgraded my Ubuntu Gusty to Hardy. Everything was Ok, since I played with firefox. Some heavy loaded pages (like Amazon, or Gmail) was damn sloowwwww ! Playing with scroll was a source …… grrrrrr ….Firefox on Hardy is 3.0b5. This version has a major “feature” the use a Xrender for the page display. And this looks like Xrender is dawn slow on Nvidia cards .. In fact, Nvidia has already work on this kind of issue before. Without looking forward I decided to run a little benchmark, with the help of friends with Xrenderbenchmark. So here the results.

Benchmarks

Benchmarks was done by me and 2 firends, on Q6600 or E6600 Intel CPU running at 2.4Gh, with kernel 2.6.24.1. The graphs only show the Plain results (not Plains + Alpha, or Transformation) but the results are quite the same anyways.

Legend:

  • 8600GT/nv : Nividia 8600GT / Xorg 1.4.1git 32 bits / Nvidia GPL driver
  • 8600GT/nvidia : Nividia 8600GT / Xorg 1.4.1git 32 bits / Nvidia binary driver ver: 169.12
  • 8600GT/nividia-64 : Nvidia 8600GT / Xorg 1.4.1git 64 bits / Nvidia binary driver ver: 169.12
  • Intel GMA X300 : Intel GMA 3000 / Xorg 1.4.0.9 64 bits / Intel GPL driver
  • ATI HD2600PRO : ATI HD 2600 Pro / Xorg 1.4.1git 64 bits / ATI GPL driver

I split the results into two graphs for convenience.

As you can see on this first part, numbers are really small, the Nvidia GPL driver is the worst : 5 times slower than any other one. Not a good news, and the binary one have some bad results on 2 tests. ATI HD and Nvidia drivers offer quite the same results, but remenber this is the GPL ATI driver ! … The Intel doesn’t have a lot of linearity on this part.

But the next graph give us absolutely different picture !

For every graph, Nvidia drivers (GPL, or binary, 32 or 64 bits) are at least 6 time slower. Intel perform very well, no surprise, this card are damn cool, perfect driver for linux.. but to slow in 3D to really rock. And ATI GPL driver is the clear winner of this benchmarks tests.

As my issue is the Nvidia one, I can comment the results, the GPL driver performs better than the binary one. This is not a big surprise cause, I can see it in Firefox, even it’s slow. There is difference between 64 bits and 32, but I guess this is more kernel related than the driver itself.

I’m not a video guru and only do that figure out what’s going on my computer. I publish in the hope it might help somebody else, and to find help.

Update : The numbers can be found here

Thanks to Ludo and Christian for their help !

Important update : Check the new driver results !!

Howto repair a broken USB flash drive

This is not the first time, I break a USB Drive. And I already heard some people complaining about the same stuff. But how is this possible ? Even if I use it a lot, memory and micro-controller are robust you know, no special reason for a failure (except of course some anormal write, but this is not the case here)

I decided to open this little key, to look closely. After a quick look, I didn’t find anything. So this little PCB stuff was laying on me desk, and people play with it. After a couple of weeks, I discover the memory chip is simply de-solder. My friend at work play so much with it, the failure is now apparent. Nice no ?

Hum, this little TQFN chip will be hard to solder, that’s right. But this is do-able no ? I tried this with a small soldering iron and here the result:

And yes, the key works fine right now ;) That’s fine no ? I definitively won’t trust this drive enought to store important document, but fine for a couple of mp3, or other..

Howto install KDE4 on a Ubuntu 8.10 (or 8.04)

Today, it’s the time to switch to the next Ubuntu version. One interesting stuff in the latest distro, is the KDE4, but by default you still get a 3.5.9 revision..

Here a little tips to switch easily:

First uninstall the previous version

sudo apt-get remove --purge kdebase-bin-kde3
sudo apt-get autoremove --purge

Install KDE4

sudo apt-get install kde4

As you can see, this is not really hard. The trick is to remove the old version cleanly.

Enjoy ?

Switch to wordpress

During the last rescue of this website, I ran into issue. In fact my old blog engine (Alinea) was buggy due to a lot of changes in SQLObject, Webware and docutils. I was sick to patch this days after days to maintain this. I decided to switch to a plain-old-fashin php install.

Thanks to AlineaObject lib, it doesn’t take me too much time, to do the job. I still need to fix some stuff (mainly the rewrite rules), but this look fine. I switched to WordPress. Of course I lost a lot of functionalities of my initial setup, like the Anti-SPAM feature or the ZPT template engine, but right now I get some more stuff.

I already switched 2 times before (Moveable Type, Alinea ..)

The migration works lilke a charm right now, feel free to post if you have some issues.

Lumex Graphic LCD 128×64 (S12864GSF) + AVR (Atmega32)

I recently bought 2 LCD from jckrers ebay store. I have a good idea for this stuff, but first I need to run several tests. This LCD are fine and use the common KS108 controller.

My first thought was to use the avrlib, so I wired the LCD and started to use avrlib, but I quickly run into issues. In fact, I want to use some icons on, and the avrlib seems to be buggy.

After a little compile/test/run/compile, I remember an old post on a website about KS108 chips. I find it back, it’s on the science prog

This is really great, you can build some custom fonts easily (that’s exactly what i’m looking for)..

Here a couple of pics…

http://jkx.larsen-b.com/photos/AlarmClock/DSC02817_003.sized.jpg

As you can see, I use a ATMega32 (on a futurelec card), a simple pot for the contrast, and the lumex.

http://jkx.larsen-b.com/photos/AlarmClock/DSC02816_003.sized.jpg

I can use a mix of different fonts on the same screen.

And I can even display some pics too :)

http://jkx.larsen-b.com/photos/AlarmClock/DSC02820.sized.jpg

Here the famous tux.

I still have to deal with menu and other stuff, this should be a little harder than expected, but will be nice. If somebody know a good library to use on a T6963C, please post a comment..

For users who wants high res pics, you can find them in my gallery (as usual).

MP3 Bitrates compared

A lot of people use some mp3 files right now. I decided to take a look at a spectrum analysis of a sound file at different bitrates. The result is really something, I doesn’t expected..

The original wave file is a radio (FM) recorded… I chose this one, cause this radio have a big noise on the upper part of the spectrum.

Original:

http://jkx.larsen-b.com/photos/blog/spectrum_original.png

b = 128

http://jkx.larsen-b.com/photos/blog/spectrum_128.png

b = 192

http://jkx.larsen-b.com/photos/blog/spectrum_192.png

b = 224

http://jkx.larsen-b.com/photos/blog/spectrum_224.png

Variable bitrate

http://jkx.larsen-b.com/photos/blog/spectrum_variable.png

What we clearly see, it that mp3 encoder (lame here) use a expander, and this is quite a good stuff. I think I should have normalized the input.. but..

After that point, we clearly see it cuts the around 16Khz, I know that my computer system isn’t able to achieve this level, but my stereo system can.

First results show that Ogg give a better results but this is for a future post.

Enjoy sound

Howto reinstall / restore Grub with an Ubuntu

After a windows fresh install, the windows setup decided to drop my MBR to put its stuff in. Fine .. but I want my grub back now !

This is an old trick, but udev added a little complexity, so let’s give it a try. First boot on a Ubunty CD, open a console and run:

(here my linux partition is sda2, second partition on a sata disk)

mkdir /media/mnt
mount /dev/sda2 /media/mnt/
mount -o bind /dev/ /media/mnt/dev
chroot /media/mnt

=> now you are on the destination disk, so you can install grub.
grub-install /dev/sda

Of course you can do a lot more stuff, like changing fstab etc etc .. but the trick is to mount + mount bind + chroot

My new silent computer (Intel Quad Core Q6600)

Ok, I decided to change my computer a couple of months right now. But as Intel is doing some strange stuffs with the prices, this took a little longer than exepected. Some friends asked me what I bought, so I decided to write this post.

My new box description:

Here a little photo:

http://jkx.larsen-b.com/photos/Computers/DSC02751.sized.jpg

So let’s take a look closer.. I bought the Q6600 because it has a good price right now.

For the motherboard I wanted to buy a serious brand (I had some bad issues with ASRock ..). And Asus build some good ones, but doesn’t have a PS2 keyboard plug. I choose the Gigabytes because the bridge cooler is on the right, so I can use a big fan in the case back (no cpu-fan) without the bridge fan issue.

For the harddrive, I already have this type of Seagate on another box (in ATA, not SATA), and it’s damn cool ! Low noise and great performances .. a substain 58Mo/sec (a little bit more than my previous LVDS-SCSI config at 10 000 rpm !)

The perfect box should have two 120mn fans. So this CoolMaster is fine.
I only use the front fan right now, but this may change in future. The case is quite big (too much for my needs), easy to mount, and serious quality. The hard-drive combo stuff, isn’t really easy to use but it does it’s job.

For the power-supply, after reading a lot of website, I bought the Seasonic. This stuff cost a little money, but it’s a really silent one, and seems to be robust.

As I bought a silent power supply, I needed a silent cpu cooler two. Everybody knows that default Intel fan are awfully noisy, so I decided to test this Freezer. And that was a good choice. On idle, the fan runs at 450 rpm, (hey that’s low!!) and CPU is at 31°. At full load, the fan runs at 1000 rpm (still really low!!) and the CPU is at 46°. My initial plan was to remove the fan on the cooler and to place a big 120 mn on the case back, but haven’t done this yet.

For the video card, I was looking for something with good bench on Linux, so ATI was a good challenger (beside it only works with the latest ATI binary shit). And finding a passive HD2600 is a bit hard.

For the DVD, I didn’t have any ideas. Most DVD players I used are noisy, have unstable speed. My previous Samsung was a real bullshit. I went to me local computer store, and bought the cheaper they have on stock. And this is a really good surprise. This DVD burner is really cool. So, if someone ask, give it a try :)

So, as you can imagine, this little stuff is quite silent and powerfull :)

I will upload some pictures soon …

Update: I took some photos

Enjoy cores

How to re-install WoW without wasting your time

Everybody knows that I’ used to play WoW ..ok, not really, but this is a simple tips for people who have crashed their Windows XP install or changed their harddrive (like me). Don’t waste your time to do a fresh install, just use a copy.

(C:=> main drive (new one) / E:=> backup drive )

First: copy the E:Program FilesWorld of Warcraft to C:Program Files

Next, do the same with C:\Program Files\Fichiers communs\Blizzard Entertainment

After that, you must run “WoW.exe”. (Don’t use the Launcher, it will ask you where WoW.exe is..) After this dry run, you can now run the “Launcher.exe” as usual :)

Final step, put a link on you desktop to “Launcher.exe”. Don’t forget always use Launcher.exe cause this program do the auto-update.

Update : I use a french XP install, so the path is translated in french. The right path is \Program Files\Common Files\ ..

Enjoy WoW